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Preface

This manual is primarily intended for students designing and testing VLSI integrated circuits or parts thereof at the VLSI laboratory of the DED (V2-302) using the OPUS Design Environment on PCs under the LINUX Operating System. For doing this work, first of all, you have to acquire from the system manager a personal user account in the CAD Labor Network with UID and password.

This manual consists of three main parts:

· Primer for LINUX, for persons who have not yet worked with LINUX. It provides the minimum necessary knowledge to have some orientation in the operating system and to start OPUS.

· Primer for OPUS, to start the tool and learn the simplest steps for IC design, that is schematic entry, circuit simulation, layout design and check.

· Simplified "OPUS Users´ Manual". This part is introduced by some explanations on the structure of the different tools and on the basic IC design procedure which is supported by them. It is followed by the description of selected topics about using the tools and by guidelines for the practical work. The description can not be complete, let us refer here to the many hundred pages of the online help of the program which intends to do that job. However, it is hoped that what is described here can make design work efficient for students under leadership of inspectors.

Last but not least it should be mentioned, too, what this manual does not comprise: theory and technology of silicon devices and integrated circuits. This kind of knowledge is prerequisite.

Experience with Windows is of advantage. In spite of running under LINUX the window system of OPUS shows much similarity with Windows.

Conventions Used

There will be several conventions used in this manual. The mouse has only two buttons but the scrolling wheel between them can be depressed, too, this will be referred to as the middle button. In the following there is some terminology explained which will be used in relation to mouse operations.

click left

quickly press and release the left mouse button

click middle

quickly press and release the middle mouse button (scrolling wheel)

click right

quickly press and release the right mouse button

drag left

press and hold the left mouse button while moving the mouse

drag middle

press and hold the middle mouse button while moving the mouse

drag right

press and hold the right mouse button while moving the mouse

If more than one OPUS window is open then the relevant window will be specified by adding WWW: for the window WWW.

If a double target xxx->yyy is specified with clicking, that may happen to be two separate clicks at xxx and yyy or a drag from xxx to yyy, depending upon how the popup menu for yyy comes up.

<...>
depress the key on the keyboard that corresponds to what is inside the brackets (either a character or a special key like CR (carriage return or enter), ESC (escape), SHIFT, CTRL, ALT.

type something
you should type (verbatim) whatever is printed boldfaced.

LINUX Primer

Basic LINUX Instructions

(Linux instructions have to be typed in a console (’shell’) window. All instructions have to be terminated with <CR>!)

ls


list:

lists elements of a directory by their names

ls –l
list long:
detailed listing of a directory: access right, owner,





length, date, name

ls –a


list all:

list including the hidden files too (beginning with '.')

ls –al


list all long:
detailed long listing of all files

ls –lt


long listing ordered by the time of generation

mkdir dirname
make directory named dirname
rmdir dirname

remove (delete) the directory dirname (only if the directory is empty)

rm filename

remove (delete) the file filename
du
disk usage
lists the complete hierarchy downwards with size (1 kByte blocks)

cd subdir

change directory to subdir
cd


change directory to the home directory of the user

kate filename

opens the file filename for editing (new file if filename does not exist)

About LINUX

After logging in LINUX comes up with the panel bar at the bottom and with the first of three different desktops activated. Then with a left click at the Konsole icon you have to open a Konsole shell window. This window can be your workhorse as long as you are working direct with LINUX. When a new shell opens you are at the highest level of your user account. This is your Home Directory, which can be referred to by the tilde '~' character.

The directory where you are can be represented by the dot '.', the preceding higher level directory by two dots '..'. You can move up and down among the directories with the cd command.

Typing ls -al you will find among others the file .bashrc which contains settings for the operating system. (If it does not yet exist you may open a new one with the editor.) The following two lines show examples for your own usage:

alias lth='ls -lt | head'

If you type lth then LINUX will produce a time-ordered list of the ten most recent files - an alias which can be favourably used for checking the recent changes in the directory.

alias ed='kate'

Instead of kate xxx you can simply type ed xxx and the editor will start with the file xxx. An ampersand '&' after the filename will make the editor start as a stand-alone process so that your window remains free for other work.

Any change in .bashrc will be effective only after your next logging-in.

HINT:
If you copy ~gaertner/.bashrc to your home directory then you will have these and several other features in your account:

cp ~gaertner/.bashrc  . <CR>
When already copied, you can add other aliases for your personal usage, too.

OPUS Primer

The objective of this part is to teach a quick and easy start into the Cadence system without going into details. Going through this primer a simple inverter will be designed making the following steps:

schematic entry,

drawing a symbol,

simulating the circuit with eldoD of Mentor Graphics (Spice),

designing the silicon layout,

design rule check (DRC),

circuit extraction,

electrical rule check (ERC), 

(not yet realized)
comparison layout versus schematic (LVS),

simulation of the extracted netlist.

This primer alone can bring you to the above-mentioned results. It is recommended, however, to first read the introductory chapter of the manual, because the basic background knowledge acquired there will make it easier to follow and understand the procedures.

LINUX preparation

Open a subdirectory for the priming activities. Type mkdir ams37. ams37 will be the home directory for OPUS in your account. All OPUS activities will take place inside this directory.

Starting OPUS

The very first start only initializes the design environment. Left click at the icon IC Design Framework on the desktop. A new LINUX shell comes up and asks for the design-directory of OPUS. Type ams37 <CR>, the name of the recently established subdirectory.

In return OPUS offers the available technologies. AMS 0.35 um CMOS (c35b3) has to be used, so type 1<CR>. Then OPUS reports that several setup files have been created. This happens only at the first start of OPUS. Afterwards send this window to the panel with a left click at the upper right corner.
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Fig. 1 Command Interpreter window

OPUS goes on. The Log window appears with some logging messages, then it changes to the msfb-Log window which is called the Command Interpreter Window (CIW) because it can accept commands which you type in (Fig. 1.). The library manager window, too, starts automatically, but here you have to exit OPUS by clicking at msfb:File->Exit. So the initialization is done. When you start again, clicking at the icon, then OPUS won’t ask any more question and you can go on using the library manager window.

The library manager window can be used for opening existing libraries or cells or creating new ones. The left column of the library manager window is a list of the current (accessible) libraries. Among these PRIMLIB contains the transistors you will need for the inverter.

Left click at PRIMLIB. The middle column shows the elements of PRIMLIB. Left click at nmos4. This is the basic n-MOS transistor. In the third, rightmost column you can see several views of nmos4. Of these you will need the symbol view for the schematic and the layout view for building the layout.
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Fig. 2 Library Manager window

Create a new working library

Before building the schematic you have to create a working library. In the Library Manager left click at File->New->Library. A dialog box appears, asking for the place and name of the new library (Fig. 3.).
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Fig. 3 New Library dialog box

Leave the directory at the default, and enter a name for your working library where you are going to design the inverter, such as, for instance, mylib. Left click the OK button. Cadence now creates a new subdirectory named mylib in its home directory (ams37). A new window will appear asking information about the technology file. The second option, Attach to an existing techfile, will be used, click at it. Then click on the OK button. A small dialog box appears asking for the existing techfile (Fig.4.). Left click at the Technology Library button. A list of possible choices pops up. Click at TECH_C35B3 and then OK. Your library is created now and you should be able to locate the new library mylib in your Library Manager.
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Fig. 4 Choosing the technology for the project

Create the schematic of the inverter

In the Library Manager left click on File->New->Cell view. The Create New File form appears (Fig. 5.). 
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Fig. 5 Specifying the name and view of a new cell

Type a meaningful name in the Cell Name block, such as e.g. myinv. In the View Name block type schematic or from the Tool menu choose Composer-Schematic and the View Name block will be automatically filled. Set the library for the would-be cell mylib. Left click the OK button. The Virtuoso Schematic Editing window should show up (Fig. 6:).
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Fig. 6 Schematic Editing window

Left click Virtuoso Schematic Editing:Add->Instance. The Add Instance dialog box appears (Fig. 7.). Type PRIMLIB in the Library field. To choose a four-terminal NMOS transistor type nmos4 in the Cell field and symbol in the View field. Note that you can use the Browse button in order to browse through the libraries and find the cell you want. Generally, typing in known names is faster.

When OPUS learns that you want to place an instance of a transistor then it adds fields to the box for the parameters of the transistor, already containing default values. Just change the Width to 2u (two microns).
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Fig. 7 Add Instance – specifying a transistor

Move the cursor into the editing window. Notice that there is an nmos transistor there instead of the normal cursor. Position it where you want to put the transistor, and place it by a left click. Having placed the first component, change the name of the transistor in the dialog box to pmos4 and the width to 5u. Now you have prepared the second half of the inverter and you should place the pmos transistor somewhere over the nmos device so that they can be connected by a straight line. If you type <ESC> then the dialog box disappears and OPUS is waiting for your next command. This will be adding external pins for the inverter.

Left click Add->Pin. The Add Pin dialog box appears (Fig. 8. next page). Type in out in the Pin Names field for the pins of the inverter. Set the Direction to input. (Note that the order of the pins is not important. You may even place one pin at a time and repeat the procedure.)

Move the cursor into the editing window. A pin symbol appears with a small square at the right edge. Place it left of the transistors in the middle with a left click. 

In the dialog box in disappears from the pin-list, only out remains. Change the Direction to output. In the editing window an output pin symbol appears, having a small square at the left edge. Place it right of the transistors in the middle with a left click.

In a simple case power supply pins (vss, vdd) should be added, too. However, in an IC power supply is provided in a centralized way. In the schematics it is done by the global nodes gnd! and vdd! while in the layout there are the power rails which do it. Global node names end with an exclamation point (!). Contact to the global nodes gnd! and vdd! is established by placing instances (small symbols) of the cells ground and vdd. They are stored in the library analogLib. The procedure is the same as for the transistors. Invoke the Add Instance window with a left click at Add->Instance. Select with the browser the library analogLib and then the cells ground and vdd. Place them underneath and over the transistors, respectively.

[image: image8.png]& Add Pin

Pin Names in out
Direction input Bus Expansion 4 off  on
Usage schematic Placement 4 single _ multiple
Attach Net Expression: 4 No - Yes
Property Hame
ovtautt ret tame |
Font it Font Seyie
Justfication fowerCentor | gy Stgle  fiked affsat
Rotate Sideways | Upside Down| Show Sensitivity »>
Hide | Cancel | Defaults| Help





Fig. 8 Add Pin dialog box with pin specification

Now we'll add the wires to make things work. Click Editing:Add->Wire. Notice that as you get closer to one pin than to another (including those on devices), a small diamond will show up inside of or around that pin. That is where you can click to connect a wire.

To begin with, left click the diamond at the pin of the symbol vdd, then left click on the source terminal of the PMOS transistor. The first connection is finished. Now left click on the drain terminal of the PMOS transistor and then on that of the NMOS transistor. Follow that with a wire from the source of the NMOS transistor to the pin of gnd. Make one more vertical connection between the gates of both transistors. Now, left click on the diamond in the in pin. Move the cursor horizontal to the wire you connected the two gates together with. A diamond will form around the cursor, as long as it is on the wire. Left click. You have just connected the input to the gates of both transistors. Repeat the procedure from the output pin to the wire connecting the drains of both transistors.
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Fig. 9 Complete circuit diagram of the inverter

What remains is connecting the bulk (body) terminals of the transistors. Left click on the bulk terminal of the PMOS transistor. Move the cursor a little right, and left click. The wire will turn here. Now move upwards halfway to vdd. Left click again and move to the wire connecting the drain and vdd. Connect the bulk of the NMOS transistor to vss in a similar manner.

If you happen to put a wire where you don't want it to go, you can delete it by left clicking Editing:Edit->Delete and then left click on the object you want to delete (wire, pin, component, etc.).

Once you have done editing, left click the check mark (√) icon on the left side of the screen. This will check your work for connection errors and will save your cell (more exactly: its schematic view!) in the library. You can accomplish the same by left clicking Editing: Design->Check and save. Fig. 9 shows what the complete schematic should look like.

This very simple schematic of an inverter will likely be flawless but in more complex designs OPUS may find errors which will be highlighted after the check (blinking). In such a case you may click Editing:Check->Find Marker. Then the Find Marker window opens (Fig. 10.) and you will find there the list of the highlighted errors and warnings with the reasons stated.
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Fig. 10 The window for the list of errors and warnings

Plotting the Schematic of the Inverter

Now that the schematic is complete, you will want to print it out. To do this left click Editing:Design->Plot->Submit. The submit Plot window should appear (Fig. 11, next page). The default settings usually comprise your schematic and the plotter nearby, so a click on the OK button will start plotting. Ensure that the Header button is NOT selected. This option would produce an extra page with general information on your plot like name and size etc..

If the paper box of the plotter is empty and you happen to want to plot on a sheet of paper which only has one free (empty) side, then make sure that the empty side of the paper looks downwards.

Create a symbol for the inverter

The symbol editor lets you create a "black box" description of a cell using labels, pins, shapes, notes and a selection box. Symbols enable you to introduce hierarchy into your designs. In the Library Manager left click on File->New->Cell view. The Create New File form appears. Ensure that the library name is mylib. Fill in the cell name myinv and the view name symbol. Left click the OK button. The Virtuoso Symbol Editing window should show up. (Fig. 12. on the next page shows it with the would-be result.).
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Fig. 11 Sending a circuit diagram to the plotter

Start drawing with a triangle to represent the inverter body. Left click Editing:Add->Shape->Polygon. To draw a polygon, left click at a start point and then click at the corners of the shape you want to create. To finish the polygon, click again on the start point. Since we have an inverter, we need an "inverter-like" triangle.

As to the size of the symbol: Note that there are small white dots in the black background of the editing window. If you carefully move the cursor then you will find that its movement is quantized, between two dots it can make 16 small jumps. The triangle should occupy about a "4 by 4 jump" area.

The inverter needs a negation circle at the sideways corner of the triangle, so left click Editing:Add->Shape->Circle. Left click at the would-be center of the circle and then at the corner of the triangle. A radius of "one jump" is recommended.

Next you have to create pins for the symbol. It is similar to creating pins in the schematic but the pins look different. They consist of a little red dot and of a piece of line. The dot is the pin itself. The line binds it to the body of the symbol, its length can be adjusted.
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Fig. 12 Symbol Editing window with the symbol

Left click Editing:Add->Pin. The Add Pin box shows up. Type the pin names, they must exactly match those of the schematic: in out. Do not forget to set the correct direction for the pins before placing them. Moving the cursor to the editing window the pin appears. With left clicks on Add Pin:Rotate you can change the direction of the connecting line. Place the pins so that the red dots are at the far end and the connecting lines join the body of the symbol. At last the position of the pin names have to be adjusted so that the symbol looks nice. Moving the cursor to a name a yellow box appears around it. Now you can left drag the name to its final position.
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Fig. 13 Adding a label to the symbol

Next we want to add two labels to the symbol. Left click Editing:Add->Label. The Add Symbol Label dialog box should appear (Fig. 13.). The usual default setting is [@instanceName], Label Choice: instance label, Label Type: NLPLabel. With this setting you only have to move the cursor to the editing window. The label [@instanceName] at once appears and you can place it with a left click. The next label is the name of the cell. Fill into the label field myinv and choose Label Type normalLabel. Place it again with a left click.

The last thing to add is a selection box. This will tell the software how much of the symbol is actually used. Left click Editing:Add->Selection Box. Left click the Automatic button. The selection box will be automatically drawn.

The symbol is now finished and you can save it by left clicking Editing:Design->Save. If the pin names and attributes do not match those of the schematic then warnings show up and you have to correct the mismatch.

Simulate the schematic

The functionality of an integrated circuit is verified by simulation. For a simulation the following things are needed:

· netlist

· power supply

· input signal source

· stimuli 

The netlist can be extracted from the schematic, it is usually done automatically. Power and input signals are provided by generators. They might be directly added to the schematic but this method is not recommended. Instead, a test bench should be built which takes the cell to be tested as an instance and provides the necessary simulation environment. This has several advantages. The cell remains unchanged and independent of the simulation. It is quite easy to simulate and compare different versions and views of the cell, you only have to specify a cell and a view in the test bench.

Create a test bench

To keep things apart, test benches are usually built in a separate library. For this reason open a new directory testlib just the same way you created mylib for the schematic of the inverter (page 4).  Then open a new cell with schematic view,  e.g.  test_inv.  The first element of the testbench is the cell to be tested. Left click Editing:Add->Instance. A dialog box comes up and you can either type Library mylib, Cell myinv, or you can browse through the libraries and specify it there. Place the symbol of the inverter in the middle of the screen.
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Fig. 14 Specifying a pulse generator

Left click Add->Instance->Browse. Select the generator vdc from the library analogLib. Set the field DC Voltage to 5 V. This will be the power supply, place it far left. Now you might go on browsing for other components but in this case it can be done easier, too. Change the name of the cell to vpulse and close it with a <TAB>. The dialog box changes and parameter fields of the pulse generator appear (Fig. 14.). Voltage 1 is the low level of the pulse, fill in 0. Voltage 2 is the high level of the pulse, fill in 5 for 5 Volts. Specify the timing as follows: Delay time = 2n, Rise time = .1n, Fall time = .1n, Pulse width = 5n, Period = 10n. This generator will drive the inverter, you may change the Instance Name to drv, and place it near the input of the inverter. Change the name of the cell to cap and close it with a <TAB>. The dialog box changes and now the value of the capacitive load can be set to .3p (0.3 pF). Place the capacitor near the output of the inverter.

Now left click Add->Wire or type simply <w>. Make the common ground net connecting the lower terminals of the three components. Next connect vpulse to the input and the capacitor to the output of the inverter. Place one more piece of wire to the output and add an output pin named out (left click Add->Pin, etc.). Left click Editing:Add->Wire Name. Fill in Names: uin. Move the cursor to the wire connecting vpulse and the input of the inverter and place the name onto it. In the next step you have to provide for the global vdd!. It is done by placing a vdd symbol from the library analogLib and connecting it to the positive terminal of the vdc generator.

It is important for the simulator that the ground net has the name gnd! and the internal node number zero. This can be achieved by placing one more component. Left click again Editing:Add->Instance and fill in: analogLib for the Library and gnd for Cell name. Place the ground symbol underneath and connect it to the ground net by a piece of wire. If you happen to get very unusual and unlikely voltage values resulting from the simulation then check if this condition is fulfilled! The test bench is complete, left click Design->Check and Save (Fig. 15.). 
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Fig. 15 Testbench  –  test environment for the inverter

Spice simulation with eldoD of Mentor Graphics

We are going to analyze the DC transfer characteristics and the transient behavior of the inverter. Open the schematic test_inv in the library testlib. Left click Tools->Analog Environment. The Virtuoso Analog Design Environment window opens (Fig. 16). In the status bar (second from top) the default simulator Spectre is displayed. In order to change the simulator left click Setup->Simulator/Directory/Host. The Choosing Simulator window opens. The simulator box displays Spectre. Left click on the box and select eldoD, then click OK (Fig. 17.). Check the change in the status bar of the Design Environment window.
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Fig. 16 Analog Environment  --  main control panel

Left click Analyses->Choose. The Choosing Analyses dialog box comes up. Now specify the simulation. Select Analysis: dc (Fig. 18, next page), switch off Print Operating Point, select Sweep Variable: Source (1). Next you specify Sweep Range. Fill in Start 0 and Stop 5 and By 0.01. Left click at the box Select S1. Switch over to the schematic and select the the sweeping source by clicking at the pulse generator drv at the input of the inverter. Then switch back to the Choosing Analyses dialog box. In the 1stSource field /drv should appear. See if the Enabled checkbox is switched on and click at Apply. In the same window you can specify the transient simulation as well. Select tran and set From Time 0, To Time 25n. Switch on the Enabled checkbox and click OK. In the Analyses field of the Analog Environment window the specified data appear.
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Fig. 17 Choosing the eldoD simulator
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Fig. 18 Selecting simulation parameters

Next we want to select which results should be plotted. Left click on Analog Design Environment:Outputs->To be Plotted->Select on Schematic. Click on the wire between your pulse generator and the in pin of your inverter bearing the label input. Then click on the wire between the out pin of the inverter and the out pin of the test bench. Both wires should change color indicating that these voltages will be plotted.

Note: if you want to select a current to be plotted then click on the square of a symbol where the current is flowing through. There will be a circle around the square node indicating that a current is selected. Try it with the vss and vdd terminals of the inverter. A second click on the same square cancels the selection.

Now you are ready to run the simulation. Left click Simulation->Run or click on the green traffic light icon on the right side of the Analog Design Environment window. If a dialog box appears now requiring your decision whether some simulation results should be saved then your answer must be Yes!

The simulation runs and after a while the results will be plotted in two different ways. The first is the Waveform Window of Opus, you should ignore it by simply closing. The second one is the window of the display program EZwave which we are going to use. Extend this window to the whole screen and arrange the results neatly side by side. 
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Fig. 19 Simulation results in the EZwave window

The results are plotted in the same coordinate-system. You can separate them by a right click inside the window and activate Split in the pop-up menu (Fig. 19). On the right side of the curve you see the colour-code and the name of the curve. To unite curves you can select the curve by left-click at its name and then left-drag the highlighted name to another one.

To finish the simulation exit eldoD Spice. Left click on Analog Design Environment: Session->Quit. Remember NOT to save the current state. If you choose to save then several hundreds of megabytes will be used in order to save your last simulation.

Note: the specified simulations in the Analyses field can be enabled and disabled one by one. To do so select the simulation by a left click and then left click Analog Design Environment:Analyses-> Enable or Disable (or even Delete).

Exercise using the cursors and the slope function

Read the section Simulation: EZwave Window, Cursors and Slope (page 35) and do the following exercise. Start the DC Sweep simulation of the inverter again, with the curves out and uin. When the EZwave window opens with the curves make it to form a large square on the screen. Now find three characteristic points of the output curve of the inverter:

1. The inflexion point where the slope of the curve, and so the voltage gain of the stage, is maximal

2. Determine the noise immunity of the inverter by finding those two points of the curve where the slope is just -1. The distance of these points from the end of the curve (0 or VDD, respectively) can be regarded as the noise margin. (One of them is shown in Fig. 20.)

3. Determine the transient times of the inverter: the propagation delay at 50% signal value and rise and fall time at the output between 10% and 90%. Arrange the transient signals in one coordinate system. So the propagation delay(s) can be determined. Apply one cursor to each curve and bring them to 2.5V. Read the time difference of the cursors at the bottom of the plot  Then delete the input curve and apply both cursors to the output curve. Set them so that they are at 0.5V and 4.5V, respectively. So you can read the rise and fall time values (Fig. 20.)
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Fig. 20 Finding voltage gain and rise time

Create the layout of the inverter

The tool for layout creation is called VIRTUOSO. Select mylib in the Library Manager and then myinv in mylib. In the View column the already existing views Schematic and Symbol appear. Left click Library Manager:File->New->Cell View. The Create New File dialog box shows up with myinv in the Cell Name field. Left click on Virtuoso in the popup menu of the tool selecting block. layout will be automatically filled in for View Name. Having clicked at the OK button two windows will appear, the Virtuoso Layout Editing window and the LSW (Layer Select) window. Adjust the layout editing window beside LSW to the rest of the screen (Fig 21. shows both windows).

The LSW window is the one you will use to choose the different layers for the IC design. It contains a list of the possible layers. Each entry is divided in three categories which are color, abbreviated name and purpose. Color shows the appearance of the layer in the layout. The abbreviation is the official name of the layer for Virtuoso, it can appear in messages, etc. 

The purpose can be drw for drawing and pin for pin, you will almost always need drw.

A layer can be activated for editing by a left click in the list. It gets a black frame as highlighting and will be displayed at the uppermost part of the LSW window (current entry for shape processing commands). 
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Fig. 21 Layout editing windows showing the target layout cell

The four buttons in the next line control the visibility and selectability of all shape elements: AV = all visible NV = none visible AS = all selectable NS = none selectable. When switching on and off, the elements in the list will be grayed. The visibility of single layers can be controlled by right click, the selectability by middle click.

Some general information to the editing window:

The buttons on the left side speak for themselves. For zoom-in a rectangle can be drawn by right drag. You can return to the previous view by depressing <w> (or left click Window->Utilities-> Previous View). depressing <f> will produce a full picture.

When the mouse is inside the editing window then the X and Y coordinate values of the cursor are displayed between the title bar and the menu bar. Notice the dX and dY items, too. When creating shapes, these show distances relative to the last click. If you make a mistake at any time you can left click on Editing:Edit->Undo. 

You can refresh the drawing by a left click on Editing:Window->Redraw.

Before starting prepare the battlefield for your work. Left click Editing:Options->Display. The Display Options dialog box opens containing usual default settings. In the Display Controls block switch on the buttons Pin Names, Nets and Instance Pins. In the Grid Controls block set both X and Y Snap Spacing to 0.05. For Display levels fill in To 9. Underneath switch on the button Cellview and click on the button Save To and then OK. This means that these settings will be stored in the cell view file, so that they will be automatically set whenever the cell view will be opened (Fig. 22, next page).

One more setting: Left click Editing:Options->Layout Editor. The Layout Editor Options dialog box opens containing usual default settings (Fig. 23, next page). In the Gravity Controls block set Aperture to 0.1 and then left click OK.

Now it is time to start building the layout of your inverter myinv. The main elements are the transistors which are quite complex structures consisting of pieces of different layers. You might draw these pieces one by one, carefully complying with all design rules. 
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Fig. 22 Setting up display properties
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Fig. 23 Layout Editor Options dialog box

However, you can take advantage of the library where "prefabricated" parametrizable transistor instances can be found. They contain all details in compliance with the design rules, you only have to taylor them to your need (i.e. length and width). Left click Editing:Create->Instance. The Create Instance dialog box opens (Fig. 24, next page).

If you exactly know it then you may fill in Library and Cell Name of the cell you need. If not, click on the Browse button and find and select it in the library. Now we need (in accordance with the schematic) nmos4 from the library PRIMLIB. As soon as Virtuoso notices that a parametrizable instance has been specified, it extends the Create Instance dialog box for specifying the size of the transistor. Fill in width=2u, length is defaulted to 0.35u. Activate the button Substrate Contact. Shifting the cursor to the editing window the contour of the transistor appears. You can recognize the gate as a narrow horizontal strip. With three right clicks you can turn it 3x90 degree so that the gate is vertical and the substrate contact is on the left side. Place the transistor in this position.
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Fig. 24 Create Instance dialog box with a transistor

Repeat the procedure with a pmos4 transistor. Set the width to 5u and switch on the substrate contact. Again, with three right click bring it into a favorable position. It has a similar structure to the NMOS transistor but it is surrounded by an N-well (the layer is called NTUB). Place it above the NMOS transistor so that

· it exactly matches the horizontal position of the NMOS,

· it has a little greater distance from the NMOS than the height of that (see Fig 25.).

The transistors of the inverter have to be connected with each other: gate with gate and drain with drain. Zoom in so that these areas can well be seen and processed. In the LSW window left click on the layer MET1. Then left click Editing:Create->Rectangle. With two left clicks or one left drag make a MET1 box between the drains with the same width as those. Now change the entry layer to POLY1 and repeat the action for the gate terminals.
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Fig. 25 Placement of the transistors of the inverter

Check the correct placement of the connecting elements. In the LSW window left click at NV (nothing visible except the previously selected POLY1) and then middle click at the layer MET1. Then make a left click at Editing:Window->Redraw. Everything disappears from the screen except the selected POLY1 and MET1. They must form a continuous long bar each. In case of misplacement you may delete and repeat, or you may use the editing commands move or stretch. Afterwards click at LSW:AV and then at Editing:Window->Redraw.

Next you have to provide power supply. This inverter is supposed to be part of a standard cell design so you have to comply with the supposed standard power supply structure

· medium distance 25 um

· width 3 um. 

Set the entry layer to MET1. Left click Editing:Create->Rectangle. Make a 6 um wide and 3 um high box (dX=6, dY=3). Left click Editing:Move. Depress the special-key <F3>. The property sheet of the command Move opens. Set here the Snap Mode to anyAngle. Click at Hide. Select the MET1 box with a left click. Now you can shift it to its final place: about 1 um underneath the NMOS transistor, right and left symmetrically (see Fig. 26.). This will be the GND rail.

The VDD rail has to be positioned carefully. Left click Editing: Create Ruler (or simply depress <k>). Make a left click at the upper left corner of the recently created GND rail. Shifting the cursor upwards a vertical ruler starts. Bring it up to 22um and left click again. This way you have set the location of the lower left corner of the VDD rail (Fig. 26, next page). Now make another MET1 box of the same size for VDD and depress <K> - then the ruler disappears. 

The power rails being there, connect the source and bulk contact areas to them. Contact and a piece of MET1 are already there, you only have to place two appropriate (1.6u wide) MET1 boxes, one from the NMOS to the GND-rail, and another from the PMOS to the VDD-rail.
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Fig. 26 Ruler in the layout editor window

Now an input terminal pin has to be prepared on MET1. Left click Create->Contact. The Create Contact dialog box opens. Set Contact Type to P1_C. Width and Length is automatically at 0.4 by 0.4 um. Click at Hide and place the contact box at the left side of the poly line connecting the gates. The contact comes with a small (minimum) MET1 box around the contact hole itself. There must be a minimum distance of 0.45 um from the MET1 box of the contact to the MET1 line connecting the drains. For the pin add a piece of MET1 line, 0.7 um wide, about 1 um long, extending the MET1 square to the left.

[image: image50.bmp]Fig. 27 Dialog box for layout pins

The placement of the pins follows. Left click Editing:Create->Pin. The Create Symbolic Pin dialog box appears (Fig. 27, previous page). Select Pin Type MET1_T and enter Pin Width 0.5. Switch on the button Display Pin Name. (Important! If you forget it now then the only way to fix it later is to delete the pin and repeat the placement.) Enter the names of the pins: gnd! vdd! in out. I/O Type should be defaulted to input/Output. Bring the cursor to the middle of the GND rail and make a left click. The pin will be placed but the pin name, too, appears and has to be placed with another left click. Similarly place now vdd!. Then change the I/O Type to Input in the Create Symbolic Pin dialog box and place the pin in and, eventually, change the Pin Type to Output and place the pin out. They must lie inside the respective MET1 boxes.

For correct simulation the power pins have to be furnished with Net Expression Properties. For this action select the gnd! pin. If you find some difficulty in selecting it, open the Display Options dialog box (left click Editing:Options->Display) and switch off the display of Nets. So the small square of the pin disappears, but if you move the cursor to its (empty) place then it appears as a yellow dashed line. Now type <q> and the Edit Instance Properties dialog box opens. Check the Connectivity button. In the property sheet you can read gnd! as the Terminal Name (see Fig. 27a). Fill in Net Expression Property=gnd and its Default value = gnd! then click at OK. Repeat the same procedure for the vdd! pin, too, filling in vdd and vdd!.
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Fig. 27a. Setting Net Expression Property

The last layer to add is CELBOX (cell-box). Make it the entry layer and draw a rectangle around the cell so that everything is comprised. Do it carefully so that the box exactly coincides with the power rails. The origin (0,0) of the cell has to be adjusted to the lower left corner of the cell box. Left click Editing:Edit->Other->Move Origin. Now the coordinate axes move together with the cursor. Bring the origin to the lower left corner and place it with a left click.

Click on the Save button! You hope the layout is finished. DRC and LVS will tell you if it is really complete.

Design Rule Check (DRC)

(DRC is the most important examination the layout is subjected to. Safe chip operation can only be guaranteed if there is no violation. As long as there is even only one single violation, the production of the chip must not be started.)

DRC can be started from the layout editor window. Left click Editing:Verify->DRC. The DRC dialog box opens (Fig. 28.). 
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Fig. 28 Window for starting DRC

Check the following settings:

Checking Method:
flat
Checking Limit:

full
Switch Names:

empty  --  no entry!
Rules File:

divaDRC.rul
Rules Library:

TECH_C35B3
Machine:


local
By clicking on Apply or OK the DRC could be started now and you would get at least several violations about minimum densities which are irrelevant in this case. Therefore, they have to be excluded from the checking activities. 

Left click DRC:Set Switches. The Set Switches box pops up (Fig. 29). Left click on no_coverage then left click OK. The selected option appears in the field Switch Names. Now you can start DRC with Apply or OK. If it is free of errors then save it!
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Fig. 29 Switch for excluding the coverage function

If DRC happens to find errors then they will be reported in the Command Interpreter Window (CIW) but you can analyze them one by one. Left click Editing:Verify->Markers->Find. The Find Marker dialog box appears. Switch on the Zoom To Markers button and click on Next. The editing window will zoom to the marker and the marker text message box explains the rule violation to you so that you can correct it. You have to iterate with error corrections until you reach zero error.

Layout extraction

DRC guarantees only the manufacturability of the structures on the chip. However, the functionality of the structures has to be checked, too. For this purpose the structures will be analyzed and a netlist will be constructed ( this is called extraction. Left click Editing:Verify->Extract. The Extractor dialog box appears (Fig. 30). 
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Fig. 30 Dialog box for starting the layout extraction

Check the default settings:

· Extract Method:


flat
· Switch Names:


empty  --  no entry!
· Run-Specific Command File:

off
· Rules File:



divaEXT.rul
· Rules Library:



TECH_C35B3
· Machine:



local
Start the extraction by a click on Apply or OK. In the CIW window you get a long report which should end with Total errors found: 0. If there are errors such as structures which cannot be interpreted as a correct device then these will be highlighted and you can do find and explain markers similarly to the case with DRC errors. Afterwards you can check in the library manager whether the new view extracted for the cell myinv has appeared.

Comparison Layout Versus Schematic (LVS)

Open the extracted view of myinv. What you see is quite similar to the layout. If you zoom in you can find the schematic symbols of recognized and extracted circuit elements somewhere at the edge of the corresponding layout pieces (Fig. 31, next page). The question is if the realized circuit extracted from the layout is identical to the schematic which was the basis of its design.

Left click Editing:Verify->LVS. The LVS dialog box opens (Fig. 32, next page) with data for the extracted netlist already filled in. Either you fill in data for the schematic (Library, Cell, Schematic) or click on the browser button and select the schematic from the library by the mouse. Check other default data:

· Run Directory:
LVS
· Rules File:

divaLVS.rul
· Rules Library:

TECH_C35B3
At LVS Options switch off Rewiring. Left click at the Run button. The comparison starts. After a while the Analysis Job Succeeded message box appears and notifies you about success or failure of the LVS. Click on OK or Cancel and afterwards on LVS:Output.
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Fig. 31 Extracted transistor in the layout

[image: image32.png]© Arist LVS &

Commands Help | 5
Run Directory |LVS. Browse
Create Netist M schematic W extracted

ubrary [nyLi] ayLif

ol [nyind nying

View  [schenatic extrasted

Browse | Sel by Cursor| Browse | Sel by Cursor
Rules File divaLvs. rull Browse

Rules Library W [TECH_53558

LVS Options | Rewiring Device Fixing
Create Cross Reference I Terminals
Corespondence File | [Iva_cart_file aeate
Switch Names L
Priority [0 Run loca | [
Run Output | ErorDisplay | Monitor | Info

Backannotate | Parasitic Probe | Build Analog |  Build Mixed





Fig. 32 Window for starting LVS

A quite long report of the LVS job appears with statistics and some details about possible faults. If you can find the line

The net-lists match

that means full success for you -- supposed that the schematic is correct (Fig. 33.).
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Fig. 33 LVS report file indicating “happy end”

Simulation of the extracted netlist

The last step is to check that not only the extracted netlist matches the schematic but also the simulation results are (nearly) identical. They should be identical but the stray capacitance of the wiring may influence the transient response.

After simulating the schematic we will change the content of the inverter symbol in the testbench. (If you newly start the Analog Design Environment then you first must switch over to the eldoD simulator.) Left click on Analog Design Environment: Setup->Environment. The Environment Options dialog box opens (Fig. 34.). Change the block Switch View List to eldoD cmos_sch extracted schematic and then click on OK.
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Fig. 34 Switching to layout simulation

Now you can start the simulation and check whether it brings the expected results.

Simplified OPUS Users' Manual

This is not a real user's manual. In the introduction some background information is given on the tool itself and on the design procedure. In the second part several topics are described as an extension of the Primer section. (They may be regarded as FAQ's.) This is followed by guidelines and hints for designers of standard cells -- mainly for our students.

Introduction

Cells and Views

In OPUS the construction unit is cell. A cell does not necessarily constitute a complete logical or circuit function. It is just a set of several (or even only one) circuit elements which are on whatever basis kept together. In different phases of circuit and layout design different kinds of data are required and processed. For instance geometrical (picture) information for a circuit diagram, electrical information for a netlist (parts and their connections), and another set of geometrical data for the layout of the very same cell. These data are collected and stored in the different views of the cell, such as:

Schematic:

circuit diagram (what it looks like).

HspiceD, EldoD:
contain Spice information for the element.

Layout:

silicon structure (geometrical).

Extracted:

netlist generated by analyzing the structure of the layout.

Abstract:
contains an abstract representation of the layout for use by Cadence place & route software.

Behavioral:

the Verilog description of the cell.

For using cells as hierarchic elements they have the view:

Symbol:
"black box" representation of the cell for usage in higher levels of the circuit hierarchy.

Parametric Cells

Cells may have numeric or textual parameters. Filling in these parameters when instancing the cell may result in different shapes, size, etc. A typical case for parametric cells are the transistors used in OPUS Primer.

Cell Hierarchy

Cells are building blocks. They can be used as parts of other cells. It is always an instance of the cell, represented by a black-box symbol, with a unique instance name which is placed into the higher level cell. Neither the number of instances nor the depth of the hierarchy is limited.

File System

When starting, OPUS asks for a Home Directory which is not necessarily identical with your user's home directory. OPUS will do all its jobs in this directory, mostly in subdirectories of this one. There are only a few exceptions such as the logfile CDS.log. They are placed into the user's home directory. The most important subdirectory in OPUS' home directory is the Working Library.

A cell as such does not exist. It only exists in its views. Accordingly, in the working library, where all the cells with their data are stored, each cell is represented by a subdirectory having the name of the cell. The subdirectory contains the views of the cell which, again, are subdirectories containing several data files of the view concerned.

The great majority of the files are binary. They cannot be read or processed by text editor. Their existence may be checked on the Linux level but they must not be moved, copied, deleted or operated on by the operating system. All these tasks are organized and performed by the Library Manager of OPUS.

Selected Topics

The Primer provides all necessary information for the very first steps with OPUS. However, after having started a real design, you will be confronted with new problems and questions. The selected topics which follow are intended to help going on.

General

Windows of OPUS

The windows of OPUS have similarities in appearance and functionality to those in MS-Windows (Fig. 35.). They all have a title bar at the top having the usual 3 buttons for iconifying, making full screen and closing. Dialog boxes only have the closing button. The closing buttons (X) often do not react, in such a case some other button has to be used. OPUS just like Windows usually has a menu bar with drop-down menus. 
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Fig. 35 Typical OPUS window
Functionality of some general purpose buttons:

OK

Do it and close the window

Apply

Do it and do not close the window

Cancel

Do not do anything, close the window

Close

The same as cancel

Hide

The settings are valid and the window is iconified

Help

The help system is called

You may execute commands in different ways resulting in the same action. In case of a complete window like that of Fig. 6 (page 5) you may use the roll-down menu at the top of the window, the buttons with icons on the left, or hot keys like the ones in the OPUS Primer, referred to as <char>.

Specifying the Default Home Directory for OPUS

When coming up after start, the first activity of OPUS is a prompt for the home directory for the design activities. You may already have made myopus for this purpose (mkdir myopus). If you insert a line into your .bashrc file:

setenv AMS37_DESIGN_DIR myopus <CR>

then OPUS will offer myopus as its default home directory, so depressing only <CR> is enough (instead of typing myopus<CR>).

Attaching a New Library

If there is a library in the computer system where you can find and fetch cells for your design work then this library has to be attached to your OPUS environment. The name of the library is just the name of the directory where it is stored, and it has an absolute path in the system. These two pieces of information have to be given to OPUS. You can do that in the Library Manager of OPUS. Left click Library Manager:Edit->Library Path. The Library Path Editor window opens with columns for entering the name and the path. Then left click Library Path Editor:File->Save. This way, if necessary, you can also modify or delete libraries. Exceptionally, this is a job which may be done on LINUX level, too, by editing the file cds.lib in the home directory of OPUS.

The ESCAPE function

If an editing function is activated then it remains active until another one will be switched on. If, instead, on any reason, no active function is needed then depress <ESC> and the system returns to an idle (waiting) state.

Selecting objects

1. Move the cursor to the edge of the object or place it over it. The contour of the object changes its color and forms a dashed yellow line. (Sometime the dashed yellow line just appears because in "normal" state it is not displayed such as the selection box of an instance, see Fig. 36.) With a left click it turns to a solid white line that indicates the selected state. In case of uncertainty about what has been selected depress <q>. A property sheet appears showing among others the name of the object, too.
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Fig. 36 Selecting a transistor instance
2. Making a left drag a yellow rectangle can be drawn on the screen. All items being completely inside of the yellow rectangle will be selected by this method.

Entering Parameter Values

Parameter values consist of three parts: a number, a scaling factor (such as m for milli or u for micro) and a unit. The scaling factor must immediately follow the number, while the unit (always a full unit as V or Ohm and never mV or kOhm) must be separated by a space. For example:  13.5k  Ohm. In most cases OPUS adds the unit automatically if you do not type it.

Property sheets 

Cells consist of objects, be it a piece of wire, a rectangle, a transistor or an instance of another cell. They can be selected by mouseclick. When depressing <q> the Edit Object Properties window pops up (property sheet of the object, see Fig 37.) showing the properties (parameters) of the selected object and offering the possibility to change them. 
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Fig. 37 Property sheet of a label (wire name)
For instance, the size of a rectangle, the location or the name of an instance can be changed. Changing the name of an instance means replacing it by another one. The change will be performed only after OK or Apply is clicked at. After Apply another change may be made but, more important, if in this situation another object will be selected, then the property sheet automatically brings up the properties of the newly selected object.

Setting Parameters of Operations

When creating new objects or modifying them with editing operations you may change properties and parameters of the selected operation by depressing the special key <F3>. A small window opens offering possible changes. The possibilities depend on the operation selected. For example, you may set the width of a wire in a schematic or of a path in a layout. Different Snap Modes control the direction of a path or the direction of the movement when performing a Move. (Fig. 38.)
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Fig. 38 Property sheet of the operation move
Searching

A favorable aid in editing layout as well as schematic is the function Search or Search and Replace. From the main menu it can be invoked by clicking at Edit->Search->Find… (Relplace…). A dialog box opens with many different buttons and edit fields for specifying the search (Fig.39). The object matching the criteria will be selected. Using wild characters such as * multiple search can be done. If an object is selected it can either be edited by hand or else some property can be changed by means of the Replace function.
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Fig. 39 Search dialog box
Layout

MOS Transistor Structures

AMS 5.1.41 C35B3 is a 0,35 μm n-well process, based on a lightly doped p (π) type substrate. Here NMOS transistors can directly be constructed in the substrate while for PMOS transistors a lightly doped n (ν) type well has to be formed as a container represented by the layer NTUB. In case of an NMOS transistor source and drain are formed by two n+ zones with the poly gate in-between. The PMOS transistor has a complementary structure in that it is built in the n-well with p+ zones instead of n+. The size of the transistor is determined by the thin oxide, represented by the layer DIF and the poly stripe (POLY1) crossing it. The type of the transistor is determined by the type of diffusion. For the PMOS transistor acceptors are driven into the n-well, represented by the layer PPLUS. For NMOS transistors donors are needed, represented by the layer NPLUS. (Fig. 40.)
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Fig. 40 Complementary MOS transistors, N and P
The bulk of the NMOS transistor is the substrate itself, which can be accessed by a substrate contact. An ohmic contact to the π type substrate is made by DIF and PPLUS layers. For a PMOS transistor the bulk is the n-well to which the ohmic contact can be made by DIF and NPLUS layers. The appropriate diffusions only prepare the place for the contacts, the opening of the thick oxide occurs by placing a contact (CONT) layer and then MET1 upon them.

Building Different MOS Transistor Instances

There are several (many) design rules to comply with when building transistors. In order to make it easier for the designer OPUS offers ready-made parametrizable transistors complying with all design rules. Designers are encouraged to use these rather than construct transistors layer by layer. In addition, the parameters enable the construction of a wide variety of transistors, flexibly tailoring them for individual needs. The transistors are stored in cells and are placed into your layout as instances. Here follow some examples.

Using the layout editor Virtuoso left click at Create->Instance. Enter Library=PRIMLIB, Cell=nmos4 and View=layout and close it with a tabulator. The Create Instance window will be extended and all the adjustable parameters of the selected cell (in this case the transistor nmos4) appear. (See Fig. 24, page 18.) Some parameters which cannot be modified are grayed. In the following the parameter data fields are explained. Following the Library, Cell and View fields the Names field accepts identifier(s) for the instance(s) to be placed. You may give meaningful unique names to the instances, if you don't then OPUS automatically generates a meaningless but unique character string for each instance.

Multiple placement of a cell is also possible. The data group Mosaic specifies the matrix of the instances: number of rows, columns and the spatial frequency Delta Y and Delta X of the elements of the matrix. Default values are the single placement (1 row and 1 column) and the width and height of the cell for the Delta's.

In the field Magnification a scaling factor may be given but the default value 1 usually suffices.

The next group concerns the position of the cell to be placed, they have to be clicked at if needed. Rotate means turning 90 degree clockwise. After the fourth click it returns to the original position. Sideways and Upside Down perform mirroring at a vertical and horizontal axis, respectively. These transformations can be applied independently.

The next group of data concerns the size of the transistor (Fig. 41, next page). Width is the total width while Width stripe means the width of the elementary transistor in case of a multi-finger structure. For the latter the Number of gates has to be given, too. These data are not independent, OPUS expects

Width = Width stripe * Number of gates

The program automatically corrects Width and Width stripe depending upon Number of gates.

MOS transistor shape: There is a choice of structures with the possibilities of normal and snake. Normal is the basic rectangular form which can be flexibly tailored. Snake is a special form used mainly for power transistors.

Top or Bottom Contact: They can be switched on and off upon need. In complex transistor circuits some connections may be realized on diffusion level. Accordingly, an external contact is not always needed, e.g. see the series transistors of a NAND gate.
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Fig. 41 Parameters for size and form of the transistor
Join Gates or all drains or all sources: the choice is right, left and no. If the gates of an interdigit transistor are not joined (connected with each other) then you get a number of transistors connected parallel if sources and drains are joined or else in series if sources and drains are not joined.

Substrate contact: if there are several transistors in one well then one substrate contact is enough, the other transistors can be generated without substrate contact.

The flexibility of transistor generation is illustrated by the example of Fig. 42. showing two triple transistor groups of a NAND3 gate, the N-transistors being connected in series and the P-transistors being connected parallel
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Fig. 42 Composite transistors
1. Three cascaded N-transistors can be created out of three single nmos4 transistors with the following properties (left to right, each one is normal):

2. Rotate, Sideways, width=1 μm, length=0,35 μm, No. of gates=1, only bottom contact, Substrate contact on.

3. Rotate, width=1 μm, length=0,35 μm, No. of gates=1, all contacts off.

4. Just as previously with the bottom contact on.

These three elements are shown separately as they were generated. Then with careful Move actions they can be shifted together. The distance between the poly gates should be minimal. You can easily find out the minimum in that you shift them very near to each other and then perform a DRC. The error message which you get will state the acceptable minimum distance. Then you have to correct the position of the elements accordingly. The picture shows also the edited triple transistor.

The case of the P-transistors is different. They are generated as one three-digit pmos4 transistor with the following properties:

Rotate, width=3 μm, width stripe=1 μm, length=0,35 μm, No. of gates=3, normal, both top and bottom contacts, Join NO gates, Substrate contact on, Join all drains on, Join all sources on.

With these two transistor groups a NAND3 gate is half ready: the sources have to be connected to the appropriate power supply, the drains connected with each other produce the output, and each poly gate of the N-transistors connected with one gate of the P-transistors make the inputs.

Ready-made Contacts and Vias

Under Create Instance you may select the library TECH_C35B3. Here you will find minimum size contact structures for N and P diffusion as well as for poly: ND_C, PD_C, P1_C. They contain the minimum size squares of all layers involved. The default setting is a single contact but you may specify a matrix by setting its rows and columns. (If low contact impedance is needed then you have to place a matrix of small contacts rather than a single big one.) Similarly, there is a via structure for the transition between the metal layers MET1 and MET2, it is called VIA1_C. Stacked vias (via direct over a contact) are not allowed.

Pins

The pins of the cell are connected to the wiring network of the chip. They are usually placed on a net inside the cell, between the power rails. They may be placed on POLY1, MET1 or MET2. A general rule for pins is that they have to be available by a vertical MET2 wire in both directions up- and downward. It is rather the exception than the rule if the pin is only available on POLY1 from the routing channel. If the pins happen to be on POLY1 or MET1 then space must be left for vias descending from MET2 down to the layer of the pin. If cells contain elementary hierarchical subcells, their interconnections are considered as cell-internal. Their pins may (should!) be connected in the cell (possibly not in the routing channel). Consequently, they need not be available by a vertical MET2 wire. Just a simple example: making an AND gate using a NAND and an inverter cell. The output of the NAND should be directly connected to the input of the inverter, possibly between the power rails, because it is an internal net of the cell.

How To Make Pin Names Visible?

Display of pin names can be switched on and off generally. Left click Virtuoso Editing:Options->Display. The Display Options window (see Fig. 22, page 17) opens with the checkbox Pin Names (among several others). However, if you forgot to check the Display Pin Name box on the window Create Symbolic Pin (see Fig. 27, page 20) when the pin was placed then you must delete the pin and place it again with the box Display Pin Name checked.

Design Rules

Each silicon technology has its design rules which state what can and cannot be built, usually in terms of minimum distances. These data are proprietary and usually not public. Whether a layout design complies with these rules is checked by the DRC (design rule check) procedure. The design rules are stored in some technology files. For educational purposes there is a set of design rules installed in OPUS which does not correspond to any proprietary technology but they have to be complied with when students do their practical design activities. The most important elements of these rules are listed in Table 1 (next page).

DRC without checking percentage of coverages

Complying with minimum distances is not the only condition for successful silicon technology. The design rules also contain minimum conditions for the whole area covered by different layers on the complete chip. These conditions, however, need not be checked when designing a cell. In order to avoid meaningless error messages you can switch off these checks. In the DRC window left click at Set Switches. The Set Switches window opens. Left click at no_coverage (see Fig. 29, page 22) and then OK. If you start DRC now then it will not produce the unnecessary error messages in connection with too low coverages.

Table 1. The most important DRC rules   (listed in μm)               NOT VALID!
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Simulation

EZwave Window

EZwave is a really handy, easily usable waveform display tool. Its usage is quite self-explaining. If you do not specify any signals to be plotted in the Analog Design Environment window, then the simulation will be executed and waveform data of all nets will be stored in a .wdb file. However, no EZwave window will be opened automatically. In such a case you can open an EZwave window with a left click at Analog Design Environment:MGC Sim->EZwave New Window. The window opens and on the left you can see the signal-pane. Here the available signals can be displayed in a hierarchical style, just like a file system. You can select signal names with mouse-clicks and send them to the waveform-pane to be displayed (Fig. 43.). The curves can easily be zoomed in and out. They can be selected by left click. When you make a right click there are different functions in different pop-up menus depending upon if you directly click at a curve or in-between. On the right of the curves the color-code and the name of the curves are displayed. The names can be selected and by vertical dragging the respective curves can be united in one common coordinate system, or separated in different coordinate systems.
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Fig. 43 EZwave window
EZwave Cursors and Slope

To read the values of curves cursors can be added to the waweform-pane. After a left click at EZwave:Cursor->Add a highlighted vertical line appears just over the y axis of the coordinate system together with two textboxes displaying the x and y values. The cursor can be shifted to and fro by left drags and the values follow the position. Having two cursors the x-difference is also displayed.

Another useful feature is the slope-tool. With a right click at a curve you can choose the Add Slope entry of the pop-up menu. At that very point a tangential will be drawn to the curve and in a textbox the slope will be displayed (Fig. 44, next page).

Parametric Simulation (Transistor Characteristics)

It is possible to run a multiple simulation and display the results in a common diagram. The runs differ in that a parameter of the circuit is changed and so the influence of the parameter upon the behavior of the system can be investigated. This is the parametric simulation which needs some preparation. There is no restriction in the type of the parameter. It may be the temperature, the gate width of a transistor or the value of a resistor, etc. The simulation will be executed with double sweeping and you will get a group of parametrized curves.

[image: image44.png]T Transient resuits Gvav T K

| Plctial

g g
g g
e e
2 2

T 1B 23611N|
0 EET T

00198N)] Ulims &)

10 20 50 4
Volitage (v)





Fig. 44 Slope and cursor in the waveform window
As a simple illustration of the parametric simulation the output characteristics of an NMOS transistor will be drawn by the simulator. For this purpose a very simple circuit is needed. Take an instance of the transistor nmos4 from the library PRIMLIB and two instances of the voltage source  vdc from the library AnalogLib. Connect the voltage sources to the input and output ports of the transistor G-S and D-S, respectively. Don't forget to place a gnd symbol to the source node (Fig. 45.).
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Fig. 45 Schematics for drawing the characteristics
Select the drain voltage source and type <q>. The property sheet of the voltage source opens. Fill in Instance Name = VDS. Enter <5> in the value box of the DC voltage and click at Apply. Then select the gate voltage generator, the property sheet changes to its properties. Now enter the name VGS and again 5 Volt, and click OK. Click Add->Wire Name, enter into the dialog box ugs and uds, then click at the respective wires so they will have these labels. The complete schematic diagram is shown on Fig. 45 and is ready to be simulated. 
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Fig. 46 Switching over to the eldoD simulator
The simulation is prepared as usual: Tools->Analog Environment, switch over to the eldoD simulator (shown on Fig. 46.) and then Analyses->Choose. For output characteristic curves DC analysis has to be chosen with two Sources. The first source is /VDS, Start=0, Stop=5 and By=0.01. This will be simulated and displayed as a curve. The second source is the parameter changing in comparatively large steps: /VGS, Start=0, Stop=5 and By=1. Check the Enabled box and click OK (Fig. 47.). 

[image: image47.png]© Choosing Analyses — Virtuoso® Analog Design Envir &

Analysis 4 dc ac noise
tran noisetran st
sstac sstur sstnoise
modsst

DC Analysis

Print Operating Point.
Save DC

Sweep Variahle
Temperature
Component

W Source 1 Source 4 2 Sources

Sweep Range

start € stop S By |01
1st Source | /DS Select S1
start |G e By |1
2nd Source [/V5S Select 52

Check Safe Operating Area Limits

Enabled M

OK | Cancel| Defaults| Apply| Help





Fig. 47 Setting the parameters of the double-sweep simulation
Then click at Outputs->To be Plotted->Select on Schematic and select the drain current by clicking at the drain pin of the transistor. In the list of the selected outputs the drain current appears with yes no no in the columns Plot, Save and March. In order to have the data saved click Outputs->Setup. The Setting Outputs window opens with the table of outputs (Fig. 48.). Select the only line of the table by clicking at the signal name I0/D and change the no Save entry to yes by checking the box Will Be Saved and then click at OK. The window closes and a yes appears under Save in the table of outputs.
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Fig. 48 Setting Outputs window
Now you can start the simulation and after a while the results will be displayed in an EZwave window, shown in Fig. 49.
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Fig. 49 Output characteristics of an NMOS transistor
Guidelines for the Practical Work

Schematics
Try to draw a circuit diagram which is easy to read and understand. If there are subunits with clearly defined functions then introduce hierarchy even if the block is used only once in the circuit - it enhances readability.

Circuit diagrams of standard cells have to contain the instances of gnd and vdd from the library PRIMLIB in order to establish contact to the power supply by using the global node names gnd! and vdd!. Signals are connected to the external world by means of pins. Do not forget to specify the correct direction input or output. Set inputOutput for bidirectional or power pins! On several occasions they are checked and you may get warnings or even error messages. Similarly, be consequent in using pin names because some operations are case sensitive.

It is important to have meaningful pin names which give the reader information about the role and function of the pin. Pins must have names - internal nodes (nets), too, should be given meaningful names (Composer-Schematic Editing:Add->Wire Name). Having automatically assigned net names like NET_19, NET_34, etc. is confusing while names like ENAB_COUNT or LOAD_REG or COUNT5<4:0> help to follow the function of the circuit or to evaluate simulation results.

Use always four-terminal transistors such as nmos4 or pmos4 where bulk electrodes are separately connected.

Layout

Strategy for Building Standard Cells

The basic property of standard cells is their common height or, more precisely, their common power rail structure. In the case of the student laboratory projects this consists of two 3 μm wide horizontal MET1 stripes running parallel at a medium distance of 25 μm, hence their internal distance is 22 μm.  The lower one is the ground (global node gnd!) and the upper one is the power rail (global node vdd!). The components are placed in-between while the outer space is reserved as wiring channel.

The placement of the global pins gnd! and vdd! needs some additional setting. Their properties have to be additionally edited. After selecting them and depressing <q> the Edit Instance Properties dialog box opens. Here Connectivity has to be checked. Terminal Name is displayed (gnd! or vdd!). Net Expression Property and its Default value have to be defined as gnd and gnd! as well as vdd and vdd! respectively. 

If this property is missing then everything will run correctly with the only exception of the simulation of the extracted netlist. The LVS will not be influenced, but the simulator will not be able to connect the power supply to the power rails of the layout and, therefore, the circuit will not function at all. All voltages will be in the order of 100mV.

The great majority of the components are transistors. P-channel transistors are usually placed near the power rail. N-channel transistors are usually placed near the ground. Other components have to be placed so that they should allow for easy wiring.

Common N-well for the P-channel transistors in digital cells: Because the bulk electrodes of all transistors are connected to the power rail, they may be placed into one common N-well which is laying along the power rail. Consequently, the P-transistors do not have to have substrate contacts one by one. One bulk (substrate) contact for 50-60 μm cell width suffices.

Substrate contact of N-channel transistors: N-transistors do not have separate wells because they can be placed into the P-type substrate. However, the substrate, which is their common bulk electrode, has to be connected to the ground rail. The frequency of the substrate contacts is similar to that of the well contacts: once in every 50-60 μm cell width.

Transfer gates are different in that both their source and drain carry signals. The N-transistor is “floating” in the surrounding substrate and should have no substrate contact at all. Its bulk is connected to the ground. The P-transistor must have a separate n-well which is connected to vdd! by the well contact.

Wiring levels and directions: Beside two metal layers MET1 and MET2 poly-silicon (POLY1), too, can also be used for making connections, favorably between gate electrodes which are themselves poly. However, they are restricted for cell-internal, and possibly short, connections because of their high resistivity compared with the metal leads.

General rules for the direction of MET1 and MET2 are horizontal and vertical, respectively. However, for cell wiring these general rules have to be compromised with two other points of view:

· Try to make as much of the connections between the power rails as possible, using mainly MET1 and, if necessary, POLY1.

· Keep the cell for vertical MET2 as transparent as possible. Accordingly, if MET2 is used in the cell then it should be either vertical or only quite short if it must be laid horizontally.

If it is still not possible to make the connection between the power rails then horizontal MET1 stripes can be laid direct underneath the ground or above the power rail, and the points to be connected should be connected to this "external" lead by vertical MET2 stripes.

It is warmly recommended not to begin with the building of the cell without prior placement and routing considerations. The best way to do it is to draw simplified stick diagrams on paper. This way you can select proper places for the transistors which enable easy routing – saving by this act tedious rearrangements in the layout.

Making LVS: Frequently Encountered Problems

LVS is a very difficult job for the computer and, therefore, it has to be done by following very strict rules. Even slight differences between the original netlist and the extracted one can disturb the matching process, causing seemingly strange error messages. Errors reported in the report file (see Fig. 33.) can be inspected by a left click at LVS:Output (see Fig. 32.). 

There is always a last remedy of making “human LVS” studying the netlists and searching for differences, although it is mostly quite tiresome. In OPUS LVS creates a subdirectory LVS. In this subdirectory there are further subdirectories layout and schematic, each containing the respective netlist under the name netlist. The netlists are textfiles. They can be inspected by means of the texteditor of LINUX (kate <filename>) but they must not be changed. The syntax is not described here, however, it is quite self-explaining, (similar to Spice).

LVS maps the elements of a layout (components and interconnections) to the corresponding elements of the schematic. It begins at the terminals (pins) of the netlist but it can use node names too, which are on the highest hierarchical level (those on lower levels are irrelevant). Consequently, both pin names and highest level node names must exactly match in layout and schematic, higher/lower case included. Ground and power rails must have the names gnd! and vdd! respectively.

Instance names are irrelevant for matching but component cell names also have to match ( library name included. The components in the library have different views such as symbol for the schematic, layout for the layout and lvs for the extracted netlist. LVS can only match the views of the same cell. If unmatched components remain in the error list of LVS then you should carefully check the cell names of those components in the netlists.

If the difference in the netlist of the schematic and the layout has been found then the usual way of correction is to change the component in the schematic to that type which the extractor extracted from the layout. It is worth while mentioning that the extractor does its job upon the basis of the extractor rules file. This file contains a program for analyzing and recognizing layout structures and map them into lvs views of cells. The difference of the netlist of the schematic and the layout might be eliminated by adjusting the rules file - but the rules file is attached to a given technology and is not available for modification.

Inputs of logic gates are logically equivalent. It is irrelevant, which input of a 4-input AND gate the output of another cell is driving. But not so for LVS. The LVS of OPUS has analog character and expects exactly the same circuit structure in layout as well as in schematic. It happens quite often that the failure of LVS is caused by such a logically correct mismatch. The remedy again: rearrange in the schematic the logically equivalent input connections of the multi-input gate according to the layout

Documentation

Data Sheets

The cell design is only complete with data sheets containing all available data of the cell. Of course it is the specification which is the basis of the data sheets, for it was the basis of the design work, too. (Some data of the specification may have been modified in the course of the iterative design steps.) But there are other properties of the circuit which have not been specified. For instance: sensitivity of some parameters from supply voltage and/or temperature. Such data are only by-products of the design "as they are", but they, too, have to be determined by additional simulations and documented.

Digital Library Cells

The data sheet of a digital cell usually consists of:

· a header containing the name of the library and of the cell,

· the function of the cell,

· the schematic icon of the cell,

· the truth table of the cell,

· input capacitances,

· timing data,

· date and name of the author.

These items are self-explaining, only the timing data need a detailed description. In case of direct propagation like in combinational circuits the propagation delay in both directions l-h and h-l have to be specified, as a function of the capacitive load. This means a function of y=mx+b style where b is the delay without load and x is the capacitive load:



td = td0 + m * CL
This is an approximation of the reality which is widely used for gate level simulation of complex digital circuits. In such a case a gate is modeled with its logic function, its input capacitances and with the timing data td0 and m. When the simulator reads the netlist, for each gate it adds up the input capacitances of all connected gates and computes the actual delay for each gate. Similarly, rise time and fall time also have to be specified in the same style. According to their definition, delays are measured at 50% of the signal change while rise and fall times from 10% to 90%. 

All these data may slightly depend on the slope of the input signal. Therefore, to be realistic, it is recommended to choose the slope of the input signal near that of the output signal with a load which is equal to the input capacitance of the given circuit.

td0 and m can be determined by running two simulations of the cell: one without load and one with a typical medium-sized load such as ca. 300 fF. (It can be a typical example for the parametric simulation with Cload as parameter having the values of 0 and 300 fF.)

For data inputs of sequential circuits set-up and hold times have to be specified. Parametric simulation can help here even more than in determining the delay data. Both set-up and hold time can be determined by choosing the pulse delay of the input generator as parameter and making small steps such as 50 or 100 psec.

Fig. 50. shows a simple sample of a data sheet of an inverter.
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Fig. 50 Data sheet of an inverter
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Input Capacitance  [fF]:   IN   =   120





Timing Behaviour	Rise time	    Delay L→H	            Fall time		   Delay L→H


		        td0[ns]   m[ns/pF]     td0[ns]   m[ns/pF]      td0[ns]   m[ns/pF]      td0[ns]   m[ns/pF]


      IN  →  OUT           0.32          1.13           0.25         0.78             0.24       1.15             0.22        0.65
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